if (false == x) { ...}
as opposed to:
if (!x) { ... }
and
if (false == f1()) { ...}
as opposed to:
if (!f1()) { ... }
I think the if(false == ... version is more readable. Do you agree, or have another trick you can propose? Will it be just as fast? Thanks.
This is why I do not like !x:
if (25 == a->function1(12345, 6789) &&
45 == b->function1(12345, 6789) &&
!c->someOtherFunction(123)) { ... }
The following seems better:
if (25 == a->function1(12345, 6789) &&
45 == b->function1(12345, 6789) &&
false == c->someOtherFunction(123)) { ... }
A good compiler should generate the same code for both code blocks.
However, instead of worrying about false == f1()
vs. !f1()
, you should be way more worried about the short-circuit evaluation in this example:
if (25 == a->function1(12345, 6789) &&
45 == b->function1(12345, 6789) &&
!c->someOtherFunction(123)) { ... }
Certain compilers will generate code that will skip the execution of b->function1()
and c->someOtherFunction()
, if a->function1()
call happens to evaluate to something different than 25 - the reason being, the compiler already knows the outcome of the whole if ()
statement at that point, so it can jump at the right place.
If your code depends on a state being modified by any of the skipped functions, you might get nasty surprises.